Skip to main content
Cisco SD-WAN
Support
Product Documentation
Viptela Documentation

Routing Configuration Example

This example illustrates how to set up unicast routing in a Viptela overlay network. This network consists of one vBond orchestrator, one vSmart controller, and two vEdge routers at two different sites, as shown in the figure. The table following the figure shows the parameters for these devices.

                               s00028.png

 

vBond Orchestrator

vSmart Controller

vEdge-1 Router

vEdge-2 Router

Public IP address

184.168.0.69

Domain

1

1

1

Site ID

50

1

2

VPN

Controller for VPN 1

1

1

System IP address

1.1.1.9

1.1.1.5

1.1.1.6

WAN-facing interface

Ethernet 4 (eth4)

ge1/1

ge2/1

IP address of WAN-facing interface

10.0.16.19/24

75.0.13.15/24

172.16.10.16/24

Branch-facing interface

ge0/1

ge0/2

IP address of branch-facing interface

10.0.19.15/24

172.16.7.15/24

IP address of vEdge-facing branch router

10.0.9.17/24

172.16.17.18/24

Branch address space

7.1.1.0/24

8.8.0.0/16

Branch routing protocol

BGP

OSPF

Branch AS number

1

vSmart Controller Configuration

On the vSmart controller:

  1. Configure the system properties of the vSmart controller:​
    vSmart1(config)# system system-ip 1.1.1.9
    vSmart1(config-system)# domain-id 1
    vSmart1(config-system)# site-id 50
    vSmart1(config-system)# vbond 184.168.0.69
  2. Configure the physical transport information:
    1. Configure the IP address of the WAN-facing interface:
      vSmart1(config)# vpn 0 interface eth4 ip address 10.0.16.19/24
    2. Allow the interface to carry control-plane traffic:
      vSmart1(config)# vpn 0 interface eth4 tunnel-interface
    3. Enable the interface:
      vSmart1(config)# vpn 0 interface eth4 no shutdown
    4. Configure a default route to the WAN interface that connects to the transport cloud:
      vSmart1(config)# vpn 0 ip route 0.0.0.0/0 10.0.16.19
  3. Commit the configuration:
    vSmart1(config)# commit

Here is the full configuration on the vSmart controller:

system 
  system-ip 1.1.1.9
  domain-id 1
  site-id   50
  vbond 184.168.0.69
!      
vpn 0
  interface eth4
    ip address 10.0.16.19/24
    tunnel-interface
    !
    no shutdown
  !
  ip route 0.0.0.0/0 10.0.16.19
!

vEdge1 Router Configuration

On the vEdge1 router:

  1. OMP is enabled by default on the vEdge router. This branch network is running BGP, and we want to advertise BGP-learned routes to the vSmart controller:​
    vEdge1(config)# omp advertise bgp
  2. Configure the system properties of the vEdge1 router and the IP address of the vBond orchestrator:
    vEdge1(config)# system system-ip 1.1.1.5​
    vEdge1(config-system)# domain-id 1
    vEdge1(config-system)# site-id 1
    vEdge1(config-system)# vbond 184.168.0.69
  3. Configure the transport VPN and the transport interface:
    vEdge1(config)# vpn 0 interface ge1/1 ip address 75.0.13.15/24
    vEdge1(config-ge1-1)# tunnel-interface
    vEdge1(config-ge1-1)# no shutdown/span>
  4. Configure the default route in the transport VPN:
    vEdge1(config-vpn-0)# ip route 0.0.0.0/0 75.0.13.15
  5. For the VPN, configure BGP:
    1. Configure the local AS number:​
      vEdge1(config)# vpn 1 router bgp 1
    2. Have BGP advertise only unicast traffic:
      vEdge1(config-bgp-1)# address-family ipv4_unicast
    3. Have BGP redistribute routes that it learns, via the OMP session, from the vSmart controller:​
      vEdge1(config-bgp-1)# redistribute omp
    4. Enable and configure the BGP peer:​
      vEdge1(config-bgp-1)# neighbor 10.0.17.17 remote-as 2
      vEdge1(config-bgp-1)# no shutdown
    5. Configure the interface between the vEdge1 router and its local-site router:
      vEdge1(config-bgp-1)# vpn 1 interface ge0/1
      vEdge1(config-interface-ge1-1)# no shutdown
  6. Activate the configuration:​
    vEdge1(config)# commit

Here is the full configuration on the vEdge1 router:

omp
  no shutdown
  advertise bgp
!
system
  system-ip 1.1.1.5
  domain-id 1
  site-id   1
  vbond 184.168.0.69
!
vpn 0
  interface ge1/1
    ip address 75.0.13.15/24
    tunnel-interface 
    !
    no shutdown
  ip route 0.0.0.0/0 75.0.13.15
!
vpn 1
 router
   bgp 1
     address-family ipv4_unicast
     redistribute omp
     !
     neighbor 10.0.17.17
       no shutdown
       remote-as 2
     !
   !
 !
 interface ge0/1
   ip address 10.0.19.15/24
 !
!

vEdge2 Router Configuration

On the vEdge2 router:

  1. OMP is enabled by default on the vEdge router. This branch network is running OSPF, and OSPF automatically redistributes its learned intra-area and inter-area routes to the vSmart controller. We also want to advertise OSPF external routes to the vSmart controller:
    vEdge2(config)# omp advertise ospf external
  2. Configure the system properties of the vEdge2 router and the IP address of the vBond orchestrator:
    vEdge2(config)# system system-ip 1.1.1.6
    vEdge2(config-system)# domain-id 1
    vEdge2(config-system)# site-id 2
    vEdge2(config-system)# vbond 184.168.0.69
  3. Configure the transport VPN and the transport interface and the default route:
    vEdge2(config)# vpn 0 interface ge2/1 ip address 172.16.10.16/24
    vEdge2(config-ge2-1)# tunnel-interface
    vEdge2(config-ge2-1)# no shutdown
  4. Configure the default route in the transport VPN:
    vEdge2(config-vpn-0)# ip route 0.0.0.0/0 172.16.10.16
  5. For the VPN, configure OSPF:
    1. Configure area 0 and add the ge0/2 interface to this area:
      vEdge2(config)# vpn 2 router ospf area 0 interface ge0/2
    2. Configure the interface between the vEdge2 router and its local-site router:​
      vEdge2(config)# vpn 2 interface ge0/2 ip address 172.16.7.16/24
      vEdge2(config-interface-eth1)# no shutdown
  6. Activate the configuration:​
    vEdge1(config)# commit

Here is the full configuration on the vEdge2 router:

omp
  no shutdown
  advertise ospf external
!
system
 system-ip 1.1.1.6
 domain-id 1
 site-id   2
 vbond 184.168.0.69
!
vpn 0
  interface ge2/1
    ip address 172.16.10.16/24
    tunnel-interface
    !
    no shutdown
  !
  ip route 0.0.0.0/0 172.16.7.16
!
vpn 2
  router
    ospf
     area 0
        interface ge0/2
     exit
   exit
   !
!
 interface ge0/2
   ip address 172.16.7.16/24
   no shutdown
 !
!
  • Was this article helpful?