Skip to main content
Cisco SD-WAN
Support
Product Documentation
Viptela Documentation

tloc-extension-gre-to

sdwan interface tloc-extension-gre-to—Configure a tunnel interface over which to run TLOC extensions (on IOS XE routers only). TLOC extensions allow you to extend a TLOC, over a GRE tunnel, to another router in the branch.

vManage Feature Template

For Cisco IOS XE routers only:

Configuration ► Templates ► VPN Interface Ethernet

Command Hierarchy

sdwan
  interface interface-name
    tunnel-interface
      tloc-extension-gre-to extended-interface-ip-address

Options

IP Address of GRE Tunnel Destination
extended-interface-ip-address
GRE tunnel destination IP address of the interface that you are extended to another router in the branch.

Operational Commands

show sdwan bfd sessions
show sdwan control connections
show sdwan control local-properties
show sdwan interface
show sdwan omp tlocs

Example

Create a GRE tunnel from Router 1 to Router 2 over an L3 network. Router 2 has two circuits, one to the Internet and the second to an MPLS network. Router 1 is located at the same site, but has no circuits and is on a different L3 network.

ISRK1# show sdwan running-config
sdwan
 interface ge0/2.101
  no shutdown
  encapsulation dot1 101
  ip address 10.1.19.15/24
  mtu 1496
 !              
 interface ge0/2.102 
  no shutdown
  encapsulation dot1 102
  ip address 20.1.19.15/24
  mtu 1496
 !
 interface Tunnel1
  no shutdown
  ip unnumbered GigabitEthernet0/2.101
  tunnel source GigabitEthernet0/2.101
  tunnel mode sdwan
 !
 interface Tunnel2
  no shutdown
  ip unnumbered GigabitEthernet0/2.102
  tunnel source GigabitEthernet0/2.102
  tunnel mode sdwan
 !
sdwan
 interface ge0/2.101
  tunnel-interface
   color lte
   tloc-extension-gre-to 30.1.19.16
 !
 interface ge0/2.102
  tunnel-interface
   color mpls
   tloc-extension-gre-to 40.1.19.16
 !
!

Release Information

Command introduced in XE SD-WAN Software Release 16.9.1.

Additional Information

tloc-extension-gre-from

  • Was this article helpful?